谷姐:我们都是谷歌迷
We are all Google fans

DD OpenWrt 到小鸡鸡-KDE

Rate this post

OpenWrt 是一个路由器系统 资源占用很小 整个准系统大小也就几十MB而已

如果只是做网络通信 用这个足够了

体积小的系统可以直接DD 如果是那些几百兆的不能直接DD 体积大的要进内存救援系统mfslinux才能DD不然会出错

# 创建内存临时文件夹
mount -t tmpfs tmpfs /tmp/
cd /tmp

# 下载OpenWrt x86_64镜像
wget https://downloads.openwrt.org/releases/22.03.0-rc1/targets/x86/64/openwrt-22.03.0-rc1-x86-64-generic-ext4-combined.img.gz

# 解压
gzip -d openwrt-22.03.0-rc1-x86-64-generic-ext4-combined.img.gz

# 加载镜像
kpartx -av openwrt-22.03.0-rc1-x86-64-generic-ext4-combined.img

# 挂载镜像
mount /dev/mapper/loop0p2 /mnt

# 改SSH密码 (LUCI密码跟SSH一样)
[root@localhost ~]# openssl passwd -1 www.hostloc.com
$1$rsXLgwJ2$LHU.ix0C56QmY2TXwxYSt0

nano /mnt/etc/shadow
root:$1$rsXLgwJ2$LHU.ix0C56QmY2TXwxYSt0::0:99999:7:::

# 设置网络连接(DHCP获取IPV4 IPV6)
cat <<EOF> /mnt/etc/config/network
config interface ‘loopback’
option device ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option device ‘eth0’
option proto ‘dhcp’

config interface ‘ipv6’
option device ‘eth0’
option proto ‘dhcpv6’
option reqaddress ‘try’
option reqprefix ‘auto’
EOF

# 设置网络连接(静态IPV4 IPV6地址 注意/24 /64这些CIDR代码要根据实际来定 可以小 但是不能大 CIDR代码要包含网关 ip addr show 看地址 ip -4 route 看V4网关 ip -6 route 看V6网关)
cat <<EOF> /mnt/etc/config/network
config interface ‘loopback’
option device ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option device ‘eth0’
option proto ‘static’
list ipaddr ‘IPV4地址/24’
option ipgw ‘IPV4网关’
list ip6addr ‘IPV6地址/64’
option ip6gw ‘IPV6网关’
list dns ‘2606:4700:4700::1111’
list dns ‘2606:4700:4700::1001’
list dns ‘1.1.1.1’
list dns ‘1.0.0.1’
EOF

# 强制取消挂载
umount -l /mnt

# 取消加载镜像
kpartx -d openwrt-22.03.0-rc1-x86-64-generic-ext4-combined.img

# 让文件系统只读
echo 1 > /proc/sys/kernel/sysrq
echo u > /proc/sysrq-trigger

# DD
dd if=/tmp/openwrt-22.03.0-rc1-x86-64-generic-ext4-combined.img of=/dev/实际硬盘位置 bs=4Mstatus=progress

# 强制重启
echo 1 > /proc/sys/kernel/sysrq
echo b > /proc/sysrq-trigger

热议
2楼 403_Forbidden 3小时前

独服能不能用?会不会缺驱动!

3楼 DogeLee2 3小时前

独服能不能用?会不会缺驱动!

应该不会,我见过都有家里拿3900X当软路由的

4楼 表妹 3小时前

d到vps能干些什么

5楼 KDE 3小时前

独服能不能用?会不会缺驱动!

本来就是x86_64镜像 肯定是可以装杜甫的
还有一个efi版本
在这里
https://downloads.openwrt.org/releases/22.03.0-rc1/targets/x86/64/

6楼 breakmyheart 3小时前

很详细的技术帖 绑定

7楼 403_Forbidden 3小时前

本来就是x86_64镜像 肯定是可以装杜甫的
还有一个efi版本
在这里

有空试试

8楼 ilpl 3小时前

支持技术帖 , MAKE

9楼 hcyme 3小时前

干货,就是不太饿

10楼 hwan 3小时前

表妹 发表于 2022-5-14 20:00
d到vps能干些什么

我也想知道

12楼 1016797313 3小时前

我也想知道

也是linux,啥都能干

13楼 一江秋 3小时前

把OP部署到vps有什么用呢

14楼 KDE 3小时前

我也想知道

OpenWrt也是Linux发行版之一,只不过面向路由器嵌入式设备居多,比如华为、中兴等的光猫就是基于OpenWrt系统二次开发。

还有那个极路由(已经倒闭 火了很久)也是基于OpenWrt二次开发

Linux能干的事情 OpenWrt几乎都能干 而且占用资源小

15楼 hwan 3小时前

OpenWrt也是Linux发行版之一,只不过面向路由器嵌入式设备居多,比如华为、中兴等的光猫就是基于OpenWrt …

好吧

16楼 271308568 3小时前

上次轻量上弄了一个 不知道这个安装在云服务器有什么用

17楼 KDE 3小时前

请教大佬,mfslinux 怎么设置静态ip?

mfslinux基于OpenWrt

设置都是一样

只不过需要改/etc/config/network,然后保存到mfslinux镜像iso中的initramfs.igz文件

initramfs.igz文件是cpio打包之后由gzip再次压缩

# 设置网络连接(静态IPV4 IPV6地址 注意/24 /64这些CIDR代码要根据实际来定 可以小 但是不能大 CIDR代码要包含网关 ip addr show 看地址 ip -4 route 看V4网关 ip -6 route 看V6网关)
cat <<EOF> /mnt/etc/config/network
config interface ‘loopback’
option device ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option device ‘eth0’
option proto ‘static’
list ipaddr ‘IPV4地址/24’
option ipgw ‘IPV4网关’
list ip6addr ‘IPV6地址/64’
option ip6gw ‘IPV6网关’
list dns ‘2606:4700:4700::1111’
list dns ‘2606:4700:4700::1001’
list dns ‘1.1.1.1’
list dns ‘1.0.0.1’
EOF

如果是已经加载运行了mfslinux

就直接改/etc/config/network

然后重启网络

/etc/init.d/network restart

18楼 zxxx 2小时前

mfslinux基于OpenWrt

设置都是一样

是这个流程吗?

1. 使用 gzip 解压缩 再用 cpio 解包
2. 修改
3. 使用 cpio 打包,再用 gzip 压缩

19楼 KDE 2小时前

zxxx 发表于 2022-5-14 20:39
是这个流程吗?

1. 使用 gzip 解压缩 再用 cpio 解包

是的,然后把改好静态地址的initramfs.igz复制到mfslinux即可。

20楼 Nebula 2小时前

我想知道linux能设置用哪张网卡出口吗?如果可以,那就有点用。

PS:查了下还真可以,但是删除路由,public的网口还能连进吗?

# route del -net 0.0.0.0@删除默认网关

# route add default gw x.x.x.x eth0 (设备名)@设置默认网关(出口设备)

22楼 KDE 2小时前

Nebula 发表于 2022-5-14 20:46
我想知道linux能设置用哪张网卡出口吗?如果可以,那就有点用。

肯定可以的,路由有优先级,比如定义什么网段走那个网关,优先级多少。再来一个打底定义所有网段走那个网关,优先级最后。

23楼 KDE 2小时前

zxxx 发表于 2022-5-14 20:46
完整的流程应该是这样子了吧

在最后一步,不重新创建,我是在Win用UltraISO直接替换mfslinux中的initramfs.igz文件。

24楼 zxxx 2小时前

在最后一步,不重新创建,我是在Win用UltraISO直接替换mfslinux中的initramfs.igz文件。 …

这样更方便!

25楼 jpfree 1小时前

不是一键脚本不会用

26楼 yidaomm 1小时前

大佬们云集,感谢分享

27楼 huanx 1小时前

想象不到应用场景..

申明:本文内容由网友收集分享,仅供学习参考使用。如文中内容侵犯到您的利益,请在文章下方留言,本站会第一时间进行处理。

未经谷姐允许不得转载:谷姐靓号网 » DD OpenWrt 到小鸡鸡-KDE
分享到: 生成海报

热门文章

评论 抢沙发

评论前必须登录!

立即登录   注册

买Google Voice认准【谷姐靓号网】

Google Voice靓号列表Google Voice自助购买
切换注册

登录

忘记密码 ?

切换登录

注册

我们将发送一封验证邮件至你的邮箱, 请正确填写以完成账号注册和激活